Postagens

Mostrando postagens de Maio, 2022

Mostrar erro no PHP 7.4.3

Imagem
Mostrar erro no PHP 7.4.3 Configure o php.ini para permitir que o PHP mostre os erros para facilitar na identificação do problema no código   A referência deste guia serve para sistemas operacionais Linux Mint 20.3 e Ubuntu 20.04. Exibir os erros no código do PHP é útil para o programador identificar variáveis vazias e outras situações maléficas que atrasam o desenvolvimento do site ou comércio eletrônico. Atenção! Permita a exibição dos erros apenas no momento do desenvolvimento. Por padrão fica desativado porque os erros habilitados é considerado uma falha de segurança. Se utilizar Apache2, vá no diretório /etc/php/7.4/apache2 e edite o php.ini . Para quem desconhece, o php.ini é um arquivo de configuração com diretrivas definidas do modo como o PHP deve se comportar como tamanho máximo de arquivo para upload, uso de memória, limites de uso, quais partes podem ser usadas e outras funções. Vamos imaginar como se fosse a codificação de DNA do PHP. Com o comando: sudo nano /etc/php/7.4